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What’s changed from Logger Pro 3.2 to Logger Pro 3.2.1? 
 
Supported Operating Systems 
Mac OSX 10.3 is now supported. 
 
Enhancements 
Several printing issues corrected. 
Fixed problem with serial connection to LabPro and EWE data collection. 
Two-photogate timing mode corrected. 
 
Experiment Files 
Experiment files have been updated. 
 
International 
Logger Pro 3.2.1 is more compatible with international options. 
 
Logger Pro File Compatibility 
Logger Pro files created in version 3.2 and 3.2.1 cannot be opened in older versions of Logger Pro. 
Logger Pro files created in version 3.0 and 3.1 may be opened in Logger Pro 3.2 and 3.2.1. 

 
What’s changed from Logger Pro 3.1 to Logger Pro 3.2? 

 
Video Analysis 
Quantitative position information can be obtained from inserted videos. User can set scale, define an origin, and 
track the positions of up to three objects. Video analysis data may be synchronized with sensor data. 
 
Strip Charts 
A new strip chart graph type has been added. If the width of a strip chart is less than the data collection time, then 
the strip chart will scroll right to left as data collection or replay proceeds. 
 
Rate Functions 
The rate functions used for heart rate and respiration rate calculations has been improved to use a moving window, 
allowing more frequent updates to the reported values. 
 
TI Connect Compatibility 
Logger Pro 3.2 is compatible with TI Connect versions 1.1, 1.2 and 1.3, and will use the installed USB Graph Link 
driver for calculator data import, if one is present. 
 



Optional LabPro OS update 
You have the option to update the LabPro Operating System (OS) from 6.26 to 6.27 to obtain improved photogate 
and remote data collection behavior. If your LabPro has an OS older than 6.26, Logger Pro 3.2 will require an 
update to 6.27. To update your LabPro OS, choose Update LabPro OS from the Help menu (Windows), Logger Pro 
menu (Macintosh OS X) or Apple menu (Macintosh OS 9). 
 
 
Other changes 

• New and better sensor select dialog, with groupings of sensors. 
• Handles 60 samples a minute or hour and other unusual values with better display of time values. 
• Comma decimal separator now supported in addition to North American standard period decimal separator. 
• Additional Tool Tips added. 
• Extra smart sensors are ignored when opening a file. 
• Stainless Steel Temperature probe calibration now supported using three reference temperatures. 
• Removed extra Motion Detector calibrations because you are able to remove automatically generated calc 

columns now and they will not come back. 
• Data can now start before the movie and still be synched. 
• Improved Motion Detector calibrating. 
• Large number support increased to 1050.  

 
Install Notes 

 
There is an interaction between the Logger Pro installer and Texas Instruments TI Connect uninstaller. If TI Connect 
has been installed and subsequently removed, Logger Pro installer will refuse to run. To install Logger Pro 3.2, first 
reinstall TI Connect 1.3. An installer for TI Connect is provided on the Logger Pro 3.2 install CD. 
 
The Logger Pro 3.2 installer can not remove some installations of Logger Pro 3.1. If the installer is unable to remove the 
older version, you will be prompted to remove it using Add/Remove Programs before installing version 3.2. (Windows) 
 
Logger Pro 2.2 and Logger Pro 3.2 will successfully coexist on a single computer. 
 
LabPro Operating System Changes 6.26 (required for Logger Pro 3.1 and 3.2) and 6.27 (optional 
for 3.2) 
 
In version 6.26 sensors were allowed to warm up after pressing the START/STOP button. In 6.27 the sensors are 
warmed up at setup time. After any warmup period has elapsed, data collection begins immediately on pressing 
START/STOP. 
 
Version 6.27 updates and fixes: 

• The build has DataMate 6.15 that includes the TI-73 Application. 
• Fixed problem where communications were ignored during sensor warm up period. 
• Fixed problem of photogate timebase and analog timebase being out of sync. 
• Fixed problem of a first point of monitored (not collected) data being max value when using high speed data 

collection (DataMate), 
• Fixed problem of corrupted data if photogate state transitions during start of pendulum experiment 
• Fixed problem of using two Radiation monitors at the same time (Logger Pro) 
 

Logger Pro 3.2 Known Issues 
 
• LabPro USB driver installation must be completed while logged in as administrator. (Windows only) 

• Switching USB ports on computer may require reinstallation of USB driver, as administrator. (Windows only) 

• Meters monitoring Drop Counter sensors will only display the last point taken.  

• Setting Digital Events mode clears existing data without warning. 

• The first Motion Detector point may be bad if the target is more than 6 meters away. 



• System response time may increase when collecting a large number of data points 

• When using a Stainless Steel Temperature Probe remotely, the default calibration will be used. A custom 
calibration can be performed, but will be used only when the collection is done while attached to a computer. 

• Do not connect the USB cable to LabPro until it is powered and has given its startup beeps. 

• When updating the LabPro OS on multiple LabPros, do not disconnect a LabPro until after you click OK on the 
dialog box announcing a successful update. 

• Logger Pro 3.2 does not support 640x480 monitors. 

• To remove video analysis data, use delete, not strike-through or clear. 

• ORP Sensor users can find ready-to-use experiment files in the ORP folder in the Probes & Sensors folder. Use 
them as is, or as templates to create your own files. 

• Electrode Amplifier users can find ready-to-use experiment files in the Electrode Amplifier folder in the Probes 
& Sensors folder. Some files are set up to read millivolts, while others are designed to read pH when the 
Electrode Amplifier is being used with a pH electrode. If you are using the Chemistry with Computers lab book, 
please note that the standard experiment files which measure pH will not work properly if you are using an 
Electrode Amplifier with a pH electrode. The files you should use can be found in the EA Chem with Computers 
folder found in the Electrode Amplifier folder. 

 
What’s new in Logger Pro 3.1 

 
A major development in Logger Pro 3 is the addition of all the features of the Graphical Analysis 3 Program.  
Below is an overview of these features. 

New Feature: Import From TI Device 
You can use Logger Pro 3 to transfer the data from a Texas Instruments graphing calculator to your computer for analysis 
or printing. Supported calculators are the TI-73, TI-73 Explorer, TI-82, TI-83, TI-83 Plus, TI-85, TI-86, TI-89, TI-92, TI-
92 Plus, and Voyage 200. To do this, you need a TI-GRAPH LINK cable, which is part of the TI-GRAPH LINK package 
and is sold by Vernier Software & Technology and other Texas Instruments dealers. This cable connects the TI graphing 
calculator to the serial or USB port of your computer. 

New Feature: Import From Data Pro 
You can import data from a Palm handheld running DataPro into Logger Pro 3 for analysis or printing by selecting 
Import from…DataPro from the File menu. The Palm HotSync feature will also send data to Logger Pro. You will 
need the DataPro package, which is sold by Vernier Software & Technology. 

New Feature: Movies 
You can synchronize data collection and a movie of the experiment so that as you replay the movie, the data are 
replayed on the graph. Supported movie formats are Video clip (.avi) and all file formats supported by the 
QuickTime player. For a complete list of supported formats, visit: 
apple.com/quicktime/products/qt/specifications.html  

New Feature: Draw Prediction 
Added to Logger Pro 3 is the ability to predict what might happen in a given scenario.  In certain lab experiments, you 
might want students to predict what is going to happen before they collect data.  When you draw a prediction in Logger 
Pro 3 on the graphs, the prediction will be saved in the data table for comparisons. 

New Feature: Control Devices 
Using Logger Pro 3, you can power devices with an output signal from the function generator built into LabPro. 
You can also power and control devices using the Digital Control Unit. 

New Feature: Pages 
Logger Pro 3 now has pages.  This allows you to have different layouts of data in a single file.  One page might 
contain a graph and table with five different data collections.  Then on different pages you might perform 



comparisons between different collections or just go into each collection in more detail.  Each page can almost act as 
a different file while still sharing data with all the other pages. 

New Feature: Insert Additional Objects 
Added to Logger Pro 3 is the ability to add different objects besides the normal table and graph.  These include 
rectangles and ovals.  You can also add pictures to your experiment. Visual aids are especially useful for annotation, 
documentation, or instruction for a particular experiment. 

New Feature: Data Browser 
The Data Browser is a container for all the data in a Logger Pro file. In contrast, a given data table will not 
necessarily show all data columns.  
 
For basic use of Logger Pro, you will not need to use the Data Browser. By default, all new data columns are added to 
all data tables. However, for more complex Logger Pro sessions, you may find it useful to display only a subset of the 
possible columns in a particular data table, or you may find it useful to not display a data table at all. In these cases, you 
will use the Data Browser to manipulate data columns and data sets. 

What’s changed from older versions of Logger Pro to Logger Pro 3 
 
Below are questions you may ask if you are already familiar with older versions of Logger Pro. Also provided is a 
list of improvements and new features of Logger Pro 3.  

Interfaces 
Logger Pro 3 only supports the Vernier LabPro interface.  You can import data from text files, Excel files, different 
TI Graphing Calculators using a TI-GRAPH LINK cable, a Palm OS handheld using Data Pro and the LabPro. 
Logger Pro will not work with the ULI, Serial Box Interface, or the MPLI. 

“LabPro” and “Collect” buttons  
Logger Pro 3 keeps all buttons on the toolbar at all times.  This means that the “Collect” button will no longer 
disappear when the LabPro is not connected. Instead there is constant feedback in the upper left-hand corner of the 
toolbar that tells the user whether or not the LabPro is connected. The Collect button will be faded if LabPro is not 
connected or recognized.  

Windows 
Logger Pro 3 now uses objects instead of windows.  Every table, graph, meter, floating box and other window 
previously available in Logger Pro 2 are now separate objects in Logger Pro 3.  Each object can still be resized and 
moved.  Using the Page menu items, objects can be aligned, layered, grouped, ungrouped, and locked on a page.  To 
insert most objects, just select the object you wish to add from the Insert menu.  Floating boxes, now called helper 
objects, can still be found in the Analyze menu.  Objects also have options, which can be opened by either double 
clicking on an object or selecting the desired object and choosing it from the Options menu. 

Data Runs 
Runs from Logger Pro 2 are now called Data Sets. 

Calculated columns 
Formula Columns are now called Calculated Columns in Logger Pro 3.  Other than the name change, calculated columns 
act the same way as Formula Columns in Logger Pro 2, with some additional features like error bar calculations. 

Supported File Formats 
Logger Pro 3 can save files in Logger Pro 3 (.xmbl) or Graphical Analysis 3 (.ga3) formats.  
 
The Import Text feature, available from the File menu, can import data saved with the Export Text menu item or 
files created and saved from several other formats (e.g. Excel). The file must be in the tab-delimited text format used 



by Export Text (a .txt, .TEXT, .dat or .scv extension). Data are imported only into the latest data columns. You can 
also use this feature to import data prepared or collected in another program into Logger Pro.  

Sensor Setup 
The Setup menu has been removed. The Sensors Properties dialog has changed to the Sensor (LabPro) dialog, which 
can be accessed through the Experiment menu at any time or by clicking on the LabPro button on the toolbar when a 
LabPro is attached to the computer. 
 
If you are using LabPro with an auto-ID sensor (such as a Stainless Steel Temperature Sensor or a Motion Detector), 
Logger Pro will identify your sensor at launch and load a default data collection mode. If your sensor does not auto-
ID, choose an experiment file from the appropriate sensor folder or open the Sensor Setup dialog to manually 
configure Logger Pro for you sensor.  

Sensor Setup dialog 
The Sensor (LabPro) dialog replaces the Sensor Properties dialog from Logger Pro 2.  Its functionality is similar in 
that you can setup the sensors being used by LabPro.  Any sensor with auto-ID can be automatically added and 
configured to the sensor setup by clicking on the Auto-ID All Channels button.  To add non auto-ID sensors, either 
click on the channel box to open the Choose Sensor dialog or click on the desired sensor in the Sensor Catalogs and 
drag it to the appropriate channel.  To see the details for a connected sensor, just click on it and select Sensor Info… 
from the resulting menu to bring up the Sensor Settings dialog.  From here you can also calibrate the sensor. 

Live Readouts 
The Live Readouts menu item has moved from the Experiment menu and is now a checkbox located in the Sensor 
(LabPro) dialog available from the Experiment menu.  When selected, Live Readouts will be displayed for each 
sensor in the Sensor (LabPro) dialog as well as on the toolbar. 

Mode and Sampling 
In Logger Pro 3 these two separate pages have been combined into the Data Collection dialog from the Experiment 
menu. As you change the mode for the collection, you will notice the options available will also change according to 
your choice.  These options are similar to those in Logger Pro 2. 

Repeat mode 
In Logger Pro 2 there was a separate Repeat mode for doing a Real Time Collection with repeats.  In Logger Pro 3, 
Repeat is a checkbox option on the Time Based collection mode page of the Data Collection dialog.   

Photogate Timing modes  
Photogate Timing modes are not available in the Data Collection menu.  Click on the Photogate Channel Box in the 
Sensor Setup window to change or select timing modes.  
 
Logger Pro 3 also contains improved, more flexible functions (available in the New Calculated Column dialog from 
the Data Menu) to create calculated columns based on photogate data.  

Radiation Monitor setup 
Once the Radiation Monitor is set up in the Sensor Setup window, the sensor status will be shown. The reading will 
be in Counts. The status of the Radiation Monitor is also displayed under the Toolbar. Click on the Radiation 
Monitor Channel Box in the Sensor Setup window to change or select timing intervals.  

FFT graph and table 
To insert an FFT graph, just select it from the Insert menu under Additional Graphs.  In Logger Pro 3 there is no 
longer a separate FFT Table, instead you just use the regular data table.  You can add a new data set to hold the FFT 
data that you want or you can open the FFT Graph Options dialog and select which data sets and columns to use for 
the FFT graph.  The FFT Graph Options dialog is similar to the FFT Options dialog found in Logger Pro 2 except 



the two pages, Graph Features and FFT, have been combined into one page for easier access.  FFTs have also been 
updated to allow more than one column to be plotted on a single FFT graph. 

Histogram graph and table 
To insert a Histogram graph, just select it from the Insert menu under Additional Graphs.  In Logger Pro 3 there is no 
longer a separate Histogram Table, instead you just use the regular data table.  You can add a new data set to hold the 
Histogram data that you want or you can open the Histogram Graph Options dialog and select which data sets and 
columns to use for the Histogram graph.  The Histogram Graph Options dialog is similar to the Histogram Options 
dialog found in Logger Pro 2, but the Graph Features page has been renamed to Graph Options and the Axis Options 
page is now the Bin & Count Options page.  Histograms have also been updated to allow more than one column to be 
plotted on a single Histogram graph. 

Automatic/Manual Curve Fit 
Both types of curve fits have been merged into a single dialog in Logger Pro 3.  Logger Pro 3 includes all Logger 
Pro 2 curve fit options and many new features. For automatic curve fits, you are now able to define your own 
function for a curve fit.  The preview window now acts like a normal graph with the ability to zoom and autoscale.  
To switch between a manual and automatic curve fit, just click the appropriate radio button located in the upper right 
of the dialog under Fit Type.  After performing an automatic curve fit, you can switch to a manual curve fit to get an 
even better fit if you desire.  Sometimes it also helps to click the Try Fit button more than once to get an even better 
automatic curve fit. 

Autoscale axes 
The functionality is now in the Axes Options tab of the Graph Options dialog, which can be called up by selecting 
Graph Options from the Options menu or by double clicking on the graph.  Clicking on the axis labels on the graph 
may also change the axes.  The scaling options for each axis are now independent of each other. 

Printing 
There is no longer an option to Print Screen.  Instead, you can select Print from the File menu. 

Remote data retrieval 
Remote data retrieval from the LabPro is now in the Experiment menu.  The functionality remains the same except 
that when you setup the LabPro for remote data, you can now print out your collection settings. Retrieval of data 
from the LabPro remains the same. 

Calibration Folder 
The calibration for sensors has been updated and is now stored in a database, so it's no longer necessary to supply a 
calibration folder. 

Experiment Folder 
The experiment folder is now located within the default folder, which can be defined in the Preferences dialog. 

Over Range Autoscale option 
The Over Range Autoscale option in the Graph behavior preferences page in the Preferences dialog has been 
removed.  In Logger Pro 3 you can get the same effect by going to the Axes Options, which can be accessed either 
through the Graph Options (from the Options menu or double clicking on the graph).  There are scaling options for 
each axis, so the autoscaling can be independent of each other. 

Default Interface 
Logger Pro 3 only supports the LabPro, so there is no need to define a default interface. 

Options menu 
The Options item found in the Experiment menu in Logger Pro 2 has moved to the File menu and renamed, Settings 
for "this file.”  You will find all of the experiment options in this dialog except the Enable automatic Curve Fit 



checkbox, which has been moved to the Preferences dialog.  This new Settings dialog will save your options for the 
entire file, even after closing the file. 

Store Latest Run 
To store a set of data, choose Store Latest from the Experiment Menu. 

Information about a file 
The About "this file" item in the Help menu has been removed.  In Logger Pro 3 you can place information about a 
page in the Page Options item in the Page menu.  You can set the Page Information text in the Page Options dialog for 
page 1. You can also choose for it to be displayed when the page is first viewed, or when the file is opened. 

Undo function 
In Logger Pro 2 there was an undo command in the Edit menu.  Logger Pro 3 expands on this command and allows 
you to undo almost any action that you perform.  Collecting data, deleting or inserting an object, or changing the 
scale of the graph, for example can all be undone.  If you perform too many undos, you now have the option to 
perform a redo that essentially undoes an undo. 

Text Annotation 
Text Annotation in Logger Pro 3 has been updated with many new features.  For one, each text annotation can be 
connected to a point, thus describing information about what is happening to the graph at a particular point in time.  
As the graph is moved, the text annotation will stay with its point.  You can also have more than one text annotation 
for a single point. 

Stretchy Axes 
Just outside the X or Y-axis line, you can use the cursor to manually rescale or stretch the axis. 
 
 


