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Install Notes  
 
Logger Pro USB driver must be fully installed while logged in with administrator privileges on Windows 2000 
and XP. Unlike LabPro, Go! devices do not require administrative privileges to install.  

1. Disconnect LabPro from the computer. 
2. Log in as administrator. 
3. Install Logger Pro.  
4. Apply power to a LabPro using the AC adapter. 
5. When prompted by the installation program, connect the LabPro to the computer by USB. Follow any 

Windows wizard prompts. Connect the LabPro to each USB port that will be used with the LabPro to 
install the driver for each port.  

6. Logger Pro and LabPro can now be used by restricted user accounts. 
 

USB devices (Go!Link, Go!Temp) are not supported by Windows NT.   
 
There is an interaction between the Logger Pro installer and Texas Instruments TI Connect uninstaller. If TI Connect 
has been installed and subsequently removed, Logger Pro installer will refuse to run. To install Logger Pro 3.3, first 
reinstall TI Connect 1.3 or newer. You can download an installer from http://education.ti.com. 
 
Logger Pro 2.2 and Logger Pro 3.3 will successfully coexist on a single computer. 
 

What’s changed in Logger Pro 3.3 
 
Support for Multiple Devices 
Logger Pro 3.3 supports LabPro, Go!Temp, Go! Link, and Ohaus Scout Pro balances. Up to four devices may be 
used simultaneously, with no more than two LabPros. On Windows, only one Ohaus scale can be connected by 
USB. Note: USB devices connect automatically if detected. Serial LabPro (and Ohaus on Windows) require manual 
connection  using Connect Interface from the Experiment menu. 
 
Icons for On-Line Devices 
The second row in the toolbar now holds icons for each on-line device, followed by any live readouts. These icons 
are buttons to summon the sensor setup dialogs for each device. Offline devices do not appear in the toolbar, but are 
available in the Experiment menu. 
 
Keyboard triggering 
Keyboard triggering is a new option that allows you to start data collection with minimal delay by pressing the 
spacebar or return key on the keyboard. Enable keyboard triggering on the Data Collection dialog, Triggering tab. 



When keyboard triggering is active, clicking the Collect button merely prepares the system for data collection; 
collection begins at the next point when the spacebar is pressed.  
 
Automatic Detection of Sensor Configuration 
Logger Pro now detects the connection and removal of auto-ID sensors whenever live readouts are on and data 
collection is not active. When a sensor is added, a column is added to the Data Table. When a sensor is removed, its 
column is removed if the column is empty. To disable this behavior, turn off live readouts in the Experiment menu. 
 
Automatic Updating of Page Objects 
Logger Pro now automatically adds graphs or connects columns to existing graphs when sensors are added. This 
behavior simplifies setup, but it can also disrupt existing page layouts. As a result there are two new options to 
control automatic updates of page objects. You can separately enable or disable update page objects on File�New 
(the default is on) and after File � Open (the default is off).  
 
Single-Point Calibration 
Standard calibrations require two external references, but some sensors can be calibrated by setting an offset only, 
such as correcting a barometer for altitude. Logger Pro now allows single-point calibrations for any sensor that can 
be calibrated using two points.  
 
Identify Column Data Source 
Now that Logger Pro collects data from multiple devices it can be confusing as to where a given column is getting 
its values. You can now determine the source by device and channel number (eg, LabPro 2, CH 3) by inspecting the 
Column Options dialog for a given column. In addition, the interface dialogs (Experiments�Set Up Sensors � 
Show all Interfaces show the column name where the data from each channel is stored, in each sensor's Sensor Info 
display. 
 
Finer Control of Live Readouts 
All live readouts can still be disabled through the experiment menu but individual columns can be controlled 
through the column options.  This can be very helpful to reduce the number of live readouts displayed on the 
toolbar. You can now turn on live readouts for the Motion Detector, although then the detector will click at all times.  
 
Export to GIS Format 
Logger Pro can export data in a form recognized by GIS software such as ArcView by ESRI. 
 
New Page Objects 
There are three new page objects. The Thermometer resembles a glass thermometer and can be used to display 
sensor readings. The Analog Gauge is a dial readout for sensor readings. The Animated Display is used to represent 
the motion of objects, usually from a Motion Detector column.  
 
New Global Preferences 
New preferences have been added. Optionally you can turn on a list of recently used files to be displayed in the File 
menu. This feature lets you quickly return to recent work, but some users may want to turn off the feature so that 
students cannot easily find other student work. The default is off. You can turn on large toolbar buttons so that 
Logger Pro will look nearly like Logger Lite. The default is set for standard Logger Pro buttons.  
 
Supports New Sensors 
The new Thermocouple (version shipping after May 2004) is now supported 
 
Sensor Confirmation Dialog 
The Sensor Confirmation dialog opens when you open an experiment file and Logger Pro does not detect all the 
necessary sensors. In version 3.2.1 and earlier we assumed that some non-auto ID sensors were present. Now we 
prompt, unless the Sensor Confirmation flag is cleared in the setting for that experiment file.  
The Sensor Confirmation Dialog will disappear when you connect the requested auto ID sensors.  
You can also indicate where any non-auto ID sensors are connected and manually close the dialog.  
 



Logger Pro File Compatibility 
Logger Pro saves files in the .cmbl file format. Logger Pro opens .xmbl, .gmbl, and .cmbl files as saved by Logger 
Pro version 3.0, 3.1, 3.2 and 3.2.1, and Logger Lite. Logger Pro will also open files saved in any version of 
Graphical Analysis 3 (.ga3 extension).  
 
Other Changes 

• Grouped graph behavior links axes and doesn’t group the objects themselves. 
• Page objects now click to the front like windows in Finder and Explorer. 
• Sensor polling for new auto ID sensors is now on whenever live readouts are on. 
• Option to hide helper objects added. 
• Predictions now take on the units of the graph. 
• If no interface is connected when Logger Pro is launched, there is no longer a prompt to connect an interface, 

since Logger Pro is often used for manually entered data. 
 
Experiment Files 

• Experiment files have been updated. 
• Experiment files have been added for Workshop Physics and CPU (Constructing Physics Understanding).  
• Experiment files for Workshop Physics, CPU, Interactive Lecture Demonstrations, Real Time Physics, and 

Tools for Scientific Thinking have been moved to a folder titled Additional Physics.  
 

Logger Pro 3.3 Known Issues 
 

• Import from TI-84 series calculators must be done using a Graph Link cable, and not with the direct USB cable 
that is packaged with the calculator. 

• In Windows XP SP1, connecting a Go! device that has never been used on that specific computer, while 
Logger Pro is running, will result in a message to reboot the computer. Once that device has been used on a 
specific machine, the reboot message will not reappear. Users can avoid this one-time reboot by connecting the 
Go! device while Logger Pro is not running. Since each Go! device has a unique serial number, this reboot 
request can show up unexpectedly if the devices are moved from one computer to another. 

• Meters monitoring Drop Counter sensors will only display the last point taken.  

• Setting Digital Events mode clears existing data without warning. 
• The first Motion Detector point may be bad if the target is more than 6 meters away. 

• System response time may increase when collecting a large number of data points 

• When using a Stainless Steel Temperature Probe remotely, the default calibration will be used. A custom 
calibration can be performed, but will be used only when the collection is done while attached to a computer. 

• Do not connect the USB cable to LabPro until it is powered and has given its startup beeps. 

• When updating the LabPro OS on multiple LabPros, do not disconnect a LabPro until after you click OK on 
the dialog box announcing a successful update. 

• Logger Pro 3 does not support 640x480 monitors. 

 
What’s changed in Logger Pro 3.2.1? 

 
Supported Operating Systems 
Mac OSX 10.3 is now supported. 
 
Enhancements 
Several printing issues corrected. 
Fixed problem with serial connection to LabPro and Events with Entry data collection. 
Two-Photogate timing mode corrected. 
Remote data collection for 12000 points and four sensors now works correctly. 
 
Experiment Files 
Experiment files have been updated. 



 
International 
Logger Pro 3.2.1 is more compatible with international options. 
 
Logger Pro File Compatibility 
Logger Pro files created in version 3.2 and 3.2.1 cannot be opened in older versions of Logger Pro. 
Logger Pro files created in version 3.0 and 3.1 may be opened in Logger Pro 3.2 and 3.2.1. 

 
What’s changed in Logger Pro 3.2? 

 
Video Analysis 
Quantitative position information can be obtained from inserted videos. User can set scale, define an origin, and 
track the positions of up to three objects. Video analysis data may be synchronized with sensor data. 
 
Strip Charts 
A new strip chart graph type has been added. If the width of a strip chart is less than the data collection time, then 
the strip chart will scroll right to left as data collection or replay proceeds. 
 
Rate Functions 
The rate functions used for heart rate and respiration rate calculations has been improved to use a moving window, 
allowing more frequent updates to the reported values. 
 
TI Connect Compatibility 
Logger Pro 3.2 is compatible with TI Connect versions 1.1, 1.2 and 1.3, and will use the installed USB Graph Link 
driver for calculator data import, if one is present. 
 
Optional LabPro OS update 
You have the option to update the LabPro Operating System (OS) from 6.26 to 6.27 to obtain improved Photogate 
and remote data collection behavior. If your LabPro has an OS older than 6.26, Logger Pro 3.2 will require an 
update to 6.27.  
 
 
Other changes 

• New and better sensor select dialog, with groupings of sensors. 
• Handles 60 samples a minute or hour and other unusual values with better display of time values. 
• Comma decimal separator now supported in addition to North American standard period decimal separator. 
• Additional Tool Tips added. 
• Extra smart sensors are ignored when opening a file. 
• Stainless Steel Temperature probe calibration now supported using three reference temperatures. 
• Removed extra Motion Detector calibrations because you are able to remove automatically generated calc 

columns now and they will not come back. 
• Data can now start before the movie and still be synced. 
• Improved Motion Detector calibrating. 
• Large number support increased to 1050.  

 
 

What’s new in Logger Pro 3.1 
 
A major development in Logger Pro 3 is the addition of all the features of the Graphical Analysis 3 Program.  
Below is an overview of these features. 

New Feature: Import From TI Device 

You can use Logger Pro 3 to transfer the data from a Texas Instruments graphing calculator to your computer for analysis 
or printing. Supported calculators are the TI-73, TI-73 Explorer, TI-82, TI-83, TI-83 Plus, TI-83 Plus Silver Edition, TI-
84 Plus, TI-84 Plus Silver Edition, TI-85, TI-86, TI-89, TI-92, TI-92 Plus, and Voyage 200. To do this, you need a TI-



GRAPH LINK cable, which is part of the TI-GRAPH LINK package and is sold by Vernier Software & Technology and 
other Texas Instruments dealers. This cable connects the TI graphing calculator to the serial or USB port of your 
computer. 

New Feature: Import From Data Pro 

You can import data from a Palm handheld running DataPro into Logger Pro 3 for analysis or printing by selecting 
Import from…DataPro from the File menu. The Palm HotSync feature will also send data to Logger Pro. You will 
need the DataPro package, which is sold by Vernier Software & Technology. 

New Feature: Movies 

You can synchronize data collection and a movie of the experiment so that as you replay the movie, the data are 
replayed on the graph. Supported movie formats are Video clip (.avi) and all file formats supported by the 
QuickTime player. For a complete list of supported formats, visit: 
apple.com/quicktime/products/qt/specifications.html  

New Feature: Draw Prediction 

Added to Logger Pro 3 is the ability to predict what might happen in a given scenario.  In certain lab experiments, you 
might want students to predict what is going to happen before they collect data.  When you draw a prediction in Logger 
Pro 3 on the graphs, the prediction will be saved in the data table for comparisons. 

New Feature: Control Devices 

Using Logger Pro 3, you can power devices with an output signal from the function generator built into LabPro. 
You can also power and control devices using the Digital Control Unit. 

New Feature: Pages 

Logger Pro 3 now has pages.  This allows you to have different layouts of data in a single file.  One page might 
contain a graph and table with five different data collections.  Then on different pages you might perform 
comparisons between different collections or just go into each collection in more detail.  Each page can almost act as 
a different file while still sharing data with all the other pages. 

New Feature: Insert Additional Objects 

Added to Logger Pro 3 is the ability to add different objects besides the normal table and graph.  These include 
rectangles and ovals.  You can also add pictures to your experiment. Visual aids are especially useful for annotation, 
documentation, or instruction for a particular experiment. 

New Feature: Data Browser 

The Data Browser is a container for all the data in a Logger Pro file. In contrast, a given data table will not 
necessarily show all data columns.  
 
For basic use of Logger Pro, you will not need to use the Data Browser. By default, all new data columns are added to 
all data tables. However, for more complex Logger Pro sessions, you may find it useful to display only a subset of the 
possible columns in a particular data table, or you may find it useful to not display a data table at all. In these cases, you 
will use the Data Browser to manipulate data columns and data sets. 

 
What’s changed from Logger Pro 2 to Logger Pro 3 

 
Below are questions you may ask if you are already familiar with older versions of Logger Pro. Also provided is a 
list of improvements and new features of Logger Pro 3.  

Interfaces 

Logger Pro 3 supports the Vernier LabPro interface, the Vernier Go! Temp, the Vernier Go! Link, and the Ohaus 
Scout Pro balance. You can import data from text files, Excel files, different TI Graphing Calculators using a TI-



GRAPH LINK cable, a Palm OS handheld using Data Pro and the LabPro. Logger Pro 3 will not work with the 
ULI, Serial Box Interface, or the MPLI. 

“LabPro” and “Collect” buttons  
The “Collect” button will no longer disappear when an interface is not connected. Instead there is constant feedback 
in the upper left-hand corner of the toolbar that tells the user whether or not the LabPro is connected. The Collect 
button will be faded if LabPro is not connected or recognized.  

Windows 

Logger Pro 3 now uses objects instead of windows.  Every table, graph, meter, floating box and other window 
previously available in Logger Pro 2 are now separate objects in Logger Pro 3.  Each object can still be resized and 
moved.  Using the Page menu items, objects can be aligned, layered, grouped, ungrouped, and locked on a page.  To 
insert most objects, just select the object you wish to add from the Insert menu.  Floating boxes, now called helper 
objects, can still be found in the Analyze menu.  Objects also have options, which can be opened by either double 
clicking on an object or selecting the desired object and choosing it from the Options menu. 

Data Runs 

Runs from Logger Pro 2 are now called Data Sets in Logger Pro 3. 

Calculated columns 

Formula Columns are now called Calculated Columns in Logger Pro 3.  Other than the name change, calculated columns 
act the same way as Formula Columns in Logger Pro 2, with some additional features like error bar calculations. 

Supported File Formats 

Logger Pro 3 can open files in Logger Pro 3 (.cmbl or .xmbl), Logger Lite (.gmbl) or Graphical Analysis 3 (.ga3) 
formats.  
 
The Import Text feature, available from the File menu, can import data saved with the Export Text menu item or 
files created and saved from several other formats (e.g. Excel). The file must be in the tab-delimited text format used 
by Export Text (a .txt, .TEXT, .dat or .scv extension). Data are imported only into the latest data columns. You can 
also use this feature to import data prepared or collected in another program into Logger Pro.  

Sensor Setup 

The Setup menu has been removed. The Sensors Properties dialog has changed to the Sensor dialog, which can be 
accessed through the Experiment menu by choosing Set Up Sensors � Show All Interfaces from the Experiment 
menu. Each interface (LabPro, Go!Temp, Go! Link, or Ohaus balance) will have its own Sensor dialog. 
If you are using an auto-ID sensor (such as a Stainless Steel Temperature Sensor or a Motion Detector), Logger Pro 
will identify your sensor at launch and load a default data collection mode. If your sensor does not auto-ID, choose 
an experiment file from the appropriate sensor folder or open the Sensor Setup dialog to manually configure Logger 
Pro for you sensor.  

Mode and Sampling 

In Logger Pro 3 these two separate pages have been combined into the Data Collection dialog from the Experiment 
menu. As you change the mode for the collection, you will notice the options available will also change according to 
your choice.  These options are similar to those in Logger Pro 2. 

Repeat mode 

In Logger Pro 2 there was a separate Repeat mode for doing a Real Time Collection with repeats.  In Logger Pro 3, 
Repeat is a checkbox option on the Time Based collection mode page of the Data Collection dialog.   

Photogate Timing modes  

Photogate Timing modes are not available in the Data Collection menu.  Click on the Photogate Channel Box in the 
Sensor Setup window to change or select timing modes.  



 
Logger Pro 3 also contains improved, more flexible functions (available in the New Calculated Column dialog from 
the Data Menu) to create calculated columns based on Photogate data.  

Radiation Monitor setup 

Once the Radiation Monitor is set up in the Sensor Setup window, the sensor status will be shown. The reading will 
be in Counts. The status of the Radiation Monitor is also displayed under the Toolbar. Click on the Radiation 
Monitor Channel Box in the Sensor Setup window to change or select timing intervals.  

FFT graph and table 

To insert an FFT graph, just select it from the Insert menu under Additional Graphs.  In Logger Pro 3 there is no 
longer a separate FFT Table; instead FFT data are placed in the regular data table.  The FFT Graph Options dialog is 
similar to the FFT Options dialog found in Logger Pro 2 except the two pages, Graph Features and FFT, have been 
combined into one page for easier access.  FFTs have also been updated to allow more than one column to be plotted 
on a single FFT graph. 

Histogram graph and table 

To insert a Histogram graph, select Histogram from the Insert menu under Additional Graphs.  In Logger Pro 3 there is 
no longer a separate Histogram Table; instead histogram data are placed in the regular data table.  The Histogram Graph 
Options dialog is similar to the Histogram Options dialog found in Logger Pro 2, but the Graph Features page has been 
renamed to Graph Options and the Axis Options page is now the Bin & Count Options page.  Histograms have also been 
updated to allow more than one column to be plotted on a single Histogram graph. 

Automatic/Manual Curve Fit 

Both types of curve fits have been merged into a single dialog in Logger Pro 3.  Logger Pro 3 includes all Logger 
Pro 2 curve fit options and many new features. For automatic curve fits, you are now able to define your own 
function for a curve fit.  The preview window now acts like a normal graph with the ability to zoom and autoscale.  
To switch between a manual and automatic curve fit, just click the appropriate radio button located in the upper right 
of the dialog under Fit Type.  After performing an automatic curve fit, you can switch to a manual curve fit to get an 
even better fit if you desire.  Sometimes it also helps to click the Try Fit button more than once to improve an 
automatic curve fit. 

Autoscale axes 

The functionality is now in the Axes Options tab of the Graph Options dialog, which can be called up by selecting 
Graph Options from the Options menu or by double clicking on the graph.  Clicking on the axis labels on the graph 
may also change the axes.  The scaling options for each axis are now independent of each other. 

Printing 
There is no longer an option to Print Screen.  Instead, you can select Print from the File menu. 

Remote data retrieval 

Remote data retrieval from the LabPro is now in the Experiment menu.  The functionality remains the same except 
that when you setup the LabPro for remote data, you can now print out your collection settings. Retrieval of data 
from the LabPro remains the same. 

Calibration Folder 
The calibration for sensors has been updated and is now stored in a database, so it's no longer necessary to supply a 
calibration folder. 

Experiment Folder 

The experiment folder is now located within the default folder, which can be defined in the Preferences dialog. 



Over Range Autoscale option 

The Over Range Autoscale option in the Graph behavior preferences page in the Preferences dialog has been 
removed.  In Logger Pro 3 you can get the same effect by going to the Axes Options, which can be accessed either 
through the Graph Options (from the Options menu or double clicking on the graph).  There are scaling options for 
each axis, so the autoscaling can be independent of each other. 

Default Interface 

Logger Pro 3 allows the creation of offline interfaces, replacing the single default interface of Logger Pro 2. 

Options menu 

The Options item found in the Experiment menu in Logger Pro 2 has moved to the File menu and renamed Settings 
for "this file.”  You will find all of the experiment options in this dialog except the Enable automatic Curve Fit 
checkbox, which has been moved to the Preferences dialog.  This new Settings dialog will save your options for the 
entire file, even after closing the file. 

Store Latest Run 

To store a set of data, choose Store Latest from the Experiment Menu. 

Information about a file 
The About "this file" item in the Help menu has been removed.  In Logger Pro 3 you can place information about a 
page in the Page Options item in the Page menu.  You can set the Page Information text in the Page Options dialog for 
page 1. You can also choose for it to be displayed when the page is first viewed, or when the file is opened. 

Undo function 

In Logger Pro 2 there was an undo command in the Edit menu.  Logger Pro 3 expands on this command and allows 
you to undo almost any action that you perform.  Collecting data, deleting or inserting an object, or changing the 
scale of the graph, for example can all be undone.  If you perform too many undos, you now have the option to 
perform a redo that essentially undoes an undo. 

Text Annotation 

Text Annotation in Logger Pro 3 has been updated with many new features.  For one, each text annotation can be 
connected to a point, thus describing information about what is happening to the graph at a particular point in time.  
As the graph is moved, the text annotation will stay with its point.  You can also have more than one text annotation 
for a single point. 

Stretchy Axes 

Just outside the X or Y-axis line, you can use the cursor to manually rescale or stretch the axis. 
 
 

LabPro Operating System Changes 6.26 (required) and 6.27 (optional) 
 
Logger Pro 3 requires at least LabPro operating system 6.26. If a LabPro is connected with an earlier version, a 
dialog box will open offering to update the LabPro.  You must update the LabPro to use it with Logger Pro 3. 
Beginning in version 3.2.1, Logger Pro will update the LabPro OS to version 6.27. This update is optional, and be 
applied by connecting a LabPro, clicking the LabPro icon in the toolbar, and clicking the Update LabPro OS button 
in the Sensors dialog for that LabPro.  
 
In version 6.26 sensors were allowed to warm up after pressing the START/STOP button. In 6.27 the sensors are 
warmed up at setup time. After any warmup period has elapsed, data collection begins immediately on pressing 
START/STOP. 
 
Version 6.27 updates and fixes: 



• The build has DataMate 6.15 that includes the TI-73 Application. 
• Fixed problem where communications were ignored during sensor warm up period. 
• Fixed problem of photogate timebase and analog timebase being out of sync. 
• Fixed problem of a first point of monitored (not collected) data being max value when using high speed data 

collection (DataMate), 
• Fixed problem of corrupted data if photogate state transitions during start of pendulum experiment 
• Fixed problem of using two Radiation monitors at the same time (Logger Pro) 


