Logger Pro 3 Release Notes
Version 3.7
February 20, 2009

Contents
System Requirements
Install Notes
What's Changed in Logger Pro 3.7
Logger Pro 3.7 Known Issues
File Compatibility
What Changed in Earlier Logger Pro 3 Releases
What Changed from Logger Pro 2 to Logger Pro 3
LabPro Operating System Changes
LabQuest Operating System Changes

General System Requirements

Basic data collection or graphing, with no video capture

• Windows XP with Pentium processor, 500 MHz or better, 256 MB RAM, available USB or serial port, or
Windows Vista (32 or 64 bit) with Vista supported hardware and QuickTime version 7.1.6 or newer from
Apple supporting Vista for video playback.
• Macintosh (PPC & Intel) OS X 10.4.1, or 10.5.3 or newer with available USB port. We recommend that
Mac users use 10.4.10 or better and upgrade their systems through Apple's software update on a regular basis
for the optional experience in using Logger Pro.
• Installation requires approximately 150 MB for installation with all components, 100 MB with no movies.
• Computer display resolution 1024x768 or higher is strongly recommended. Lower resolutions result in
important controls being hidden
• For video playback or extended data collection a faster processor and more memory are suggested, such as a
1 Ghz (867Mhz G4 for Mac) processor with 0.5 GB RAM. QuickTime 7 is required for video playback.
• Data collection requires one or more of the following interfaces: LabQuest, LabPro, Go! Temp, Go! Link,
Go! Motion, WDSS, Vernier Spectrometer, select Ocean Optics Spectrometers, select Garmin GPS
receivers, Ohaus Scout or Adventurer Pro balance.
• Previous releases of Logger Pro are available for special applications. Contact Vernier for more
information.
  • Video resolutions less than 1024x768 are fully supported by Logger Pro 3.4.6 for non-video applications.
  • Window 2000 is supported by Logger Pro 3.6.0.
  • Windows 98 SE & Me are supported by Logger Pro 3.4.6.
  • Mac OS 9 is supported by Logger Pro 3.4.2; OS X 10.2 is supported by Logger Pro 3.4.5; OS X 10.3 is
    supported by Logger Pro 3.6.1.
• Windows NT is supported by earlier versions of Logger Pro 3. Windows NT does not support any USB devices.
• Windows 95 and Mac OS 8 are supported by Logger Pro 2.2.1.

**Video Capture Functions**

- Windows XP or Vista with DirectX 9 installed
- Macintosh OS X 10.4.1 or better. OS X 10.4.8 is required for Proscape HR use on Intel Macs.
- For Windows: 2 GHz single-core processor or any multi-core processor and 1GB RAM, and at least 500 MB available hard disk space for temporary storage.
- For Mac: 867 Mhz G4 processor and 1 GB RAM, and at least 500 MB available hard disk space for temporary storage.
- Screen resolution of at least 1024x768.
- Compatible camera. Recommended cameras include Firewire DV cameras, Logitech 4000 Quickcam (Windows XP only), Logitech 5000 on Vista, Apple iSight, and Proscape (HR model for Intel Macs).
- A minimal system may sometimes exhibit skipped or duplicated frames in video capture. Faster systems will exhibit fewer such problems. For most purposes these duplicated or skipped frames will not be visible.

**Wireless / Bluetooth with Vernier Wireless Dynamics Sensor System (WDSS)**

- For Windows, WDSS requires Windows XP SP 2 or newer, or Vista; the Microsoft Bluetooth Driver or WIDCOMM driver (Microsoft version recommended); Bluetooth radio compatible with installed drivers (built-in or add-on radio).
- For Macintosh, WDSS requires OS X 10.4.1 or newer (10.4.11 or newer recommended); a Mac-compatible Bluetooth radio (built-in or add-on).
- For recommended Bluetooth radios or other Bluetooth/WDSS related information, visit www.vernier.com/bthelp

**Install Notes**

There is an interaction between the Logger Pro installer and Texas Instruments TI Connect uninstaller. If TI Connect has been installed and subsequently removed, Logger Pro installer will refuse to run. To install Logger Pro 3.7 in this situation, first reinstall TI Connect 1.6 or newer. You can download an installer from http://education.ti.com.

Logger Pro 2.2, Logger Lite, Graphical Analysis, and Logger Pro 3.7 will coexist on a single computer.

Video capture and picture analysis functions in Logger Pro require QuickTime 7 installation. Normally a Logger Pro installation includes QuickTime 7 on Windows computers (Mac computers' QuickTime installations are left alone by Logger Pro installers). However if the Silent Installer method is used or if the person installing Logger Pro opts to omit QuickTime installation, you will need to install QuickTime 7 to use the picture and video functions in Logger Pro.

Vernier or Ocean Optics spectrometers no longer require a Java runtime environment as of version Logger Pro 3.5.0.

**Windows Network Installation/Remote Deployment**
• An installer for Windows that does not prompt for user input is available by request. This is useful for remote installations of Logger Pro, as this silent installer can be caused to run on a remote computer, and the installation will proceed. Write to info@vernier.com for access information.
• We do not recommend installing Logger Pro to a network location for shared access, because the necessary drivers will not be present on client machines.
• We do not recommend re-packaging a Logger Pro installation for remote deployment, because driver installation requires that a secondary installer execute at install time.

What's Changed in Logger Pro 3.7

New Device/Interface/Sensor Support

• LabQuest 1.2 devices are fully supported including sensor support for wide range temperature, heat pulser, and DCU
• Vernier GPS Device

64 bit Vista OS Support

Qualified and signed 64 bit Device drivers for LabQuest and LabPro interfaces are now available. The Logger Pro installer automatically installs these new drivers enabling full support of Logger Pro functionality on this 64 bit operating system.

Better Date & Time Display

Date and Time display on graphs is improved, providing better user feedback and the ability to plot time-based data in much more meaningful and useful ways.

Improved GPS Functionality

• Signal strength indication for VGPS devices in Live Readouts.
• Ability to select coordinate units (decimal degrees, degrees + minutes, UTM)
• Better automatic data columns based on collection mode / sensor configuration.

Changes in Auto Behavior

• An entry in the usersettings.txt file, “IDSX_MANUAL_SENSOR_CONFIG” may be used to specify if automatic setup of sensors should be turned off to support curricula that have students perform setup for data collection, etc.
• The usersettings.txt is found in the Vernier installation folder; you may find this in typical installations under your Local Disk C: > Program Files > Vernier Software > Logger Pro 3 > en-US > Support > Usersettings.txt.
• In the Usersettings.txt file find the IDSX_MANUAL_SENSOR_CONFIG entry and change the value to “1” to enable the manual mode.

Installer Packaging Improvements
The Windows installer has been migrated to use a msi package which supports easier deployment by IT personnel to multiple computers by scripting. Contact Vernier for more information.

**Significant Defects & Issues Resolved**

- Fixed: Multiplication in LabQuest calculated column fails to transfer to LP
- Fixed: Leaving LabQuest Interface window displayed in Logger Pro will cause interface disconnects.
- Fixed: cannot correctly zero a motion detector when using labpro

**Other Issues Resolved in 3.7**

- Fuller set of calculated column equations supported in Logger Pro / LabQuest data exchanges.
- Improved LabQuest remote setup.

**Logger Pro 3.7 Known Issues**

**Disabling Auto Behavior**

Logger Pro 3.7 can be configured to not automatically setup for collection based on the sensor connected in support of certain curricula; however, many devices, interfaces, etc. do not yet allow “manual” setups. Examples include Spectrometers, Ohaus balances, GoTemp, GoMotion, etc. Only sensors which use the LabPro, LabQuest, or Go!Link may be used in the manual setups.

**LabQuest file Compatibility**

Logger Pro 3.7 can open most LabQuest files correctly. Data columns will be translated correctly. However, in some cases there will be errors in calculated column translation, breaking the data import. In most cases you can manually recreate the calculated columns in Logger Pro to recover the information or use fully supported equation forms in files meant for interchange between Logger Pro and LabQuest.

Similarly, LabQuest App 1.2 can open many Logger Pro files when transferred to the LabQuest using the LabQuest Browser in Logger Pro. Elements not supported on LabQuest will be ignored, such as text annotations or movies. While LabQuest App does support calculated columns, the possible calculations are much more limited than in Logger Pro. As a result, some calculated columns will not be translated for use in LabQuest App.

**LabQuest Device Compatibility**

Logger Pro 3.7 can be used with both LabQuest 1.0, 1.1, 1.1.1, and 1.2 software. If a LabQuest with 1.0 software is detected, a warning will be displayed advising that the LabQuest unit be upgraded. This message will be displayed every time the LabQuest is detected, but the LabQuest can still be used for most applications. If a Logger Pro feature requiring newer LabQuest software is used, unexpected results such as freezing, crashing, or data loss may occur. We strongly recommend updating LabQuest to 1.2 or newer. See www.vernier.com/labquest/updates/ for information on updates.

**Vista**
Logitech 4000 cameras are not supported; use Logitech 5000 model instead.

**Windows 2000**

Windows 2000 is supported by Logger Pro 3.6.0; please use 3.6.0 for use on Windows 2000. The LabQuest interface is not supported on Windows 2000 in any version of Logger Pro.

**Mac OS 10.5 (Leopard)**

There are minor formatting issues with dialog box text. These issues are planned to be resolved in the next release of Logger Pro.

**Intel Macs**

Original Proscopes on Intel Macs requires use of Rosetta emulation mode and can be problematic; Proscope HR is recommended for Intel Macs.

Proscope usage on Intel Macs requires using Mac OS X 10.4.8 or newer. If the Apple built-in iSight camera is present it may initially appear to preclude using the Proscope models. To use an external camera on Intel Macs running 10.4.9, launch Logger Pro and insert a video capture object. Logger Pro will use the iSight. Click the Options button, and then the Camera Settings button. Click the Source tab. There you can choose to use the Proscope or other external camera as long as the drivers for that camera are present. Details may be different for other versions of the OS. Please contact Vernier if you encounter difficulties and reference TIL #1643.

**Spectrometers**

Although multiple spectrometers may be connected and used with Logger Pro, such use is not supported by Vernier. We recommend that only one spectrometer be connected at a time.

**GPS**

At this time only Garmin devices are supported with the Garmin data transfer protocol. NMEA data protocols are not supported in 3.7. Only select Garmin units and the Vernier GPS devices are supported at this time; please see www.vernier.com/gps for supported models.

COM interfaces are shown for connected VGPS devices. Attempting to re-connect to a Vernier GPS (VGPS) manually via a COM port (after disconnection for whatever reason) will not yield a usable connection and may lock up or crash Logger Pro. If there is a need to reconnect to the VGPS it is currently required for you to use the “Vernier GPS port designation in the Experiment>Connect Interface>GPS” menu.

**Adventurer Pro**

Pressing the “Unit” button on the Ohaus scale may lead to incorrect values being reported by Logger Pro. Use the Calibrate dialog in Logger Pro to set the units.
Mac OS 10.3

- Mac users of OS X 10.3 should use Logger Pro 3.6.1. You must use QuickTime 7.1.6 or newer. Specifically, QuickTime 7.1.5 and Logger Pro 3.6.1 are not compatible due to Apple specific issues on OS X 10.3.

General Issues and Suggestions for Logger Pro 3.7

- Currently you cannot insert the same movie in an experiment file (cmbl) more than once and have them share the same video analysis data set. Duplicate movies will have independent data sets.
- A known Apple QuickTime issue (versions prior to 7.5) causes cropping of videos in Logger Pro if the Logger Pro window is sized less than full screen. Video analysis will not be possible if the Logger Pro window is resized to less than full screen using obsolete QuickTime versions. Use full screen Logger Pro with using videos unless you have upgraded your QuickTime installation to version 7.5 or greater on Mac OS X 10.4 or greater (10.3 with QuickTime 7.5 continues to exhibit the cropping issue).
- Calculated columns' equations based on two or more data columns measuring the same physical quantity (such as temperature) from sensor data collected using the LabQuest interface will not be preserved if saved as a qmbl and read by Logger Pro. For example, if you measure two temperatures with the LabQuest (standalone) and save a qmbl file set with a calculated column which depends on those two temperatures, save, and reopen that qmbl file in Logger Pro, the calculated column will not work as expected. The workaround is to re-create the calculated column in Logger Pro.
- Do not connect the USB cable to LabPro until it is powered and has given its startup beeps.
- Help doesn't display correctly in Mac OS 10.4. This is a Mac OS bug; to display help properly update to 10.4.1 or newer.
- Meters monitoring Drop Counter sensors will display the last point taken.
- System response time may increase when collecting a large number of data points.
- When using a Stainless Steel Temperature Probe remotely, the default calibration will be used. A custom calibration can be performed, but will be used only when the collection is done while attached to a computer.
- When updating the LabPro OS on multiple LabPros, do not disconnect a LabPro until after you click OK on the dialog box announcing a successful update.
- User parameters cannot start with z.

- Photogate data collection can fail in digital events mode with a bad time value. This issue also affects earlier releases, and will be corrected in a LabPro firmware update. Contact Vernier Software & Technology at info@vernier.com for more information.
- On Macintosh only, picture analysis may not work if the inserted image is a .pct file. To avoid the problem, convert to .jpg in an image editing program.

Logger Pro File Compatibility

Logger Pro 3.7 can open files created in Logger Pro 3.0, 3.1, 3.2, 3.2.1, 3.3, 3.4, 3.4.1, 3.4.2, 3.4.5, 3.4.6, 3.5.0, 3.6.0, and 3.6.1. Logger Pro 3.7 can also open files created in Logger Lite (any version) and Graphical Analysis 3.0, 3.1, 3.2, and 3.4.

Files created by Logger Pro 3.7 can be opened in version 3.3 through 3.6.1, but if 3.7 features are used in the file, it will not be fully functional.

Files created by Logger Pro 3.7 cannot be opened in Logger Pro 3.0, 3.1 or 3.2.1. Graphical Analysis cannot open any Logger Pro files.
Specific File Issues

- Files created in Logger Pro 3.7 containing calculated columns with the degree symbol or micro in the column name will not open correctly in Logger Pro 3.3. To avoid the problem, remove the degree symbol or micro character while in version 3.6.1. Or, in version 3.3, find the degree or micro character you see in the column name and remove the Â.
- Files created in Logger Pro 3.3 or earlier containing column names that use the pipe character (|) will not open correctly in Logger Pro 3.7. To resolve this problem, remove the pipe character from the column names while using Logger Pro 3.3 or earlier.
- Files created in 3.7 that include calculated columns referring to a specific data set will not open properly in Logger Pro 3.3.
- Logger Pro 3.7 continues to support auto-save files as a safeguard against unexpected interruption of data collection. Increasingly, experiment files can contain large numbers of samples that take a long time to save to disk. To remedy this in 3.6.0 or later, auto-save files are now saved in a new internal format allowing, for example, files that formerly took 40 seconds to save, take only one second to auto-save.

Changes in Earlier Logger Pro Releases

Logger Pro 3.6.1

New Device/Interface/Sensor Support

- LabQuest 1.1 devices fully supported including sensor support for radiation and rotary motion
- Support for LabQuest 1.1 internal microphone

New Icon

Logger Pro 3.6.1 features new icons for the application and documents. The new icons are related to new icons used in Logger Lite 1.4.

Significant Defects & Issues Resolved

- Crashes with WDSS when used with WIDCOMM Bluetooth driver

Other Issues Resolved in 3.6.1

- Clarified wording in Remote Data Retrieval dialogs
Logger Pro 3.6.0

New Device/Interface Support

- LabQuest devices supported
- New SpectroVis Spectrometer supported
- Global Positioning System (GPS) devices supported on Mac.

New Program Features

- Autosaving during collecting is significantly faster.

Significant Defects & Issues Resolved

- Improved reliability during sensor confirmation and LabPro firmware updates.
- “Rough and slow graphing” on Macs displaying pixel ratio resolutions other than 1:1.

Other Issues Resolved in 3.6.0

- On Windows, the installers now install a version (7.2) of QuickTime supporting Vista computers.

Logger Pro 3.5.0

New Computer Operating System Support

- Windows Vista is supported on Vista compatible hardware. LabPro drivers are signed for Vista.

New Device/Interface Support

- Logitech 5000 camera for video capture.
- Garmin GPS receiver models GPSmap 60CS and GPSmap 76S.
- New Vernier CO₂ sensors with selectable range.
- Vernier and Ocean Optics Spectrometers are now supported on Intel Macs.

New Program Features

- Improved axis based zoom in/out on graphs; uses and extends the “stretchy axis” concept.
- Mac allows customization of the toolbar to suit user preferences.
• Mac User Interface conforms much more closely to Apple Human Interface Guidelines and thus should be more similar to other Mac applications. Mac Logger Pro text handling now has access to more of Mac native text handling and features.
• Numerous spectrometer connection and functional improvements. Connection/disconnection is faster and connection does not require a separate scan operation. Peak resolutions are generally cleaner and noise is diminished. Calibrations may reliably take advantage of averaging.
• Automatic graph match exercise creation feature. Access in Settings for (filename) in the File menu.
• Empty Latest data sets are now hidden on remote data retrieval.
• Movies can now be swapped without altering video analysis environment.
• Global, as opposed to per-user, preferences.
• Sensor confirmation dialog now allows connection of WDSS.
• Additional picture and movie file types available in Mac insert picture/movie object open dialogs.

Significant Defects & Issues Resolved

• Macintosh long-term data collection spanning more than 3 days is more reliable.
• Curve fits no longer require sorting data.
• Numerous graphics and print issues.
• Spectrometer calibration more robust.
• Improved stability during drop counter calibration.
• Improved reliability during sensor confirmation and LabPro firmware updates.

Other Issues Resolved in 3.5.0

• Radiation monitor and events with entry or selected events again works.
• Removed some limitations on columns choice for horizontal axis.
• Allow simultaneous heart rate monitor and blood pressure measurement.
• Restored robust movie file location search feature on Macs.
• User parameter units no longer lost.
• Data Pro Hotsync from Palm on Mac again automatically retrieves data into Logger Pro.

Logger Pro 3.4.6

New Computer Hardware Support

• Intel Architecture Macintosh computers are supported natively for the first time in Logger Pro 3.4.6 through the new Apple Universal Binary.

New Device/Interface Support

• IR Temperature Probe
• Garmin GPS USB interface initially supporting GPS Garmin Models Vista Cx and GPSmap 76S
• WDSS WIDCOMM interface (alternate Bluetooth driver) for increased Bluetooth configuration options on Windows. Note: Vernier strongly recommends using Microsoft's Bluetooth drivers on Windows XP SP2 whenever possible.

New Program Features

• Time Offset option for curve fit
• Import Logger Pro experiment files; combine several students' results in one Logger Pro file.

**Significant Defects & Issues Resolved**

• Keyboard Triggers now work properly
• WDSS repeat remote setup no longer loses trigger setting
• GO!Motion dialog for keeping remote data on device is no longer missing
• Eliminated assert on video analysis WUtil.cpp when user deletes the time column
• Improved tracking of multiple objects in video analysis

**Logger Pro 3.4.5**

**New Device Support**

• Spectrometers powered by Ocean Optics (XP, Windows 2000, Mac OS X 10.3.9 or newer)
• Wireless Dynamics Sensor System (WDSS) (XP SP 2, Mac OS X 10.3.9 or newer)
• Global Positioning Satellite (GPS) Receivers by Garmin (Windows only)
• Adventurer Pro
• Soil Moisture Sensor
• Digital Video compatible cameras and devices.

**New Program Features**

• Log Graphs (Single and Double Y Axis)
• Point and Click video / data synchronization
• Full spectrum mode, and visible spectrum graphing with Spectrometers
• Data synchronization with multiple WDSS devices (facilitates dynamics experiments that were problematic in the past)
• Export Latitude / Longitude with other data annotations as a Google Map
• Electrophoresis Gel Analysis
• Interpolation Calculator
• Photo Distance Object
• Auto resizing text annotations

**Significant Defects & Issues Resolved**

On Windows systems, Logger Pro files on read-only media (CDs etc) would fail to open due to a low level Microsoft defect. This has been corrected and Logger Pro now opens these files successfully.

Data synchronization with multiple sources is much improved and more consistent.

**Logger Pro 3.4.2**

**International**
Logger Pro 3.4.2 provides an upgrade path for 3.2.1 international users. International users should examine release note entries below for versions since 3.2.1 to gain an understanding of what has changed from 3.2.1 to 3.4.2.

**Silent Installation**

Logger Pro 3.4.2 provides and allows a silent install option for system maintainers of a large collection of machines for English only. For more information on the silent install option, please contact Vernier Software & Technology.

**Issues Resolved**

Over 80 issues were addressed by 3.4.2. The following list reflects some of the more notable issues resolved.

- Curve fits no longer fail when columns have single Greek character short column names.
- The correct curve fit now loads on opening all files saved with curve fits in versions before 3.4. This only affected saved curve fits after the polynomial fit in the curve fit menu.
- Removed a program failure that would occur if the user deleted the base column of a graph and stored the latest run.
- Changed the slope calculation to correctly account for blank cells.
- Text import now works correctly for utf8 text encoding (special characters).
- LabPro OS update no longer causes an intermittent failure.
- Curve fits with single-character x-axis labels now correctly use that label.
- Fixed program failure on keyboard entry when automatic linear fit helper object is the only object selected.
- Graph Options dialog now respects manual scale settings.
- Better LabPro driver install on Windows 2000.
- Fixed a LabPro power saving feature defect that prevented the unit from powering down in all situations.
- Fixed a Mac OS Logger Pro crash when a default folder name was left empty in the startup file.
- Fixed an issue with FFT where removal of one input column accidentally removed the source.
- Fixed text edit issues in text boxes where some characters were turned into Greek characters.
- Fixed text select and replace cursor placement issues that made certain text manipulations difficult.
- Data Delete Column should now ONLY show columns that can be deleted.
- Corrected a situation that froze Logger Pro 3.4.1 using an analog sensor and a photogate sensor.
- Opening Digital Meter Options dialog no longer intermittently shows “invalid parameter” message.
- Fixed intermittent and rare file corruption problems.
- Fixed TI Graph Link silver cable problem when upgrading from Logger Pro 3.1.
- Non-numeric entries in numeric columns are no longer lost.

**Logger Pro 3.4.1**

**Serial LabPro Communications**

Fixed issue with slow (<0.2 Hz) data collection when using serial connection to LabPro.
Logger Pro 3.4

Supported Operating Systems

Support added for Mac OS X 10.4.1 and newer.

Signed Driver

LabPro USB driver for Windows XP is now signed by Microsoft. A signed driver can be installed without displaying a hardware wizard or requiring an administrator login. Initial Logger Pro installation still requires administrative rights, but connecting a LabPro to a new USB port will no longer require such rights.

Support for New Devices

- Support added for Go! Motion.
- Support added for TI-84 and TI-89 Titanium USB direct cables.
- Support for new sensors: Blood Pressure, Charge, Spirometer, and Hand Dynamometer.

User Parameters

User parameters allow control of values used in calculations, triggering, and analog output functions.

Control objects for user parameters have been added to the Insert menu. Parameter controls are page objects, much like a digital meter, that allow adjustment of parameter values using mouse or cursor keys.

Curve Fits and Modeling

Function Plotting. Modeling no longer requires the presence of data to draw a function on a graph, so a function may be plotted alone.

Modeling is improved. Manual curve fits may be modified after the fit is drawn on the main graph.

Curve fits now optionally stored as a calculated column of user parameters. Curve fits as parameters allows the fit to be manually adjusted after the fit.

Video Features

- Video capture from many USB camera devices, with automatic insertion of movies in Logger Pro pages, has been added to the Insert menu.
- When an experiment file containing inserted videos or pictures is created or saved, the referenced video or picture file is copied to the same file location.
- Video capture done with data collection will be inserted and already synchronized, ready for replay.
- Video analysis of a still photo.
- Rotated coordinate systems for video analysis allows one-dimensional analysis of motion that is neither vertical nor horizontal.
- Display of current frame time and frame number in videos.

**Graph Features**

Double Y graphs allow plotting of values with different magnitudes on a single graph, such as pH and temperature vs. time.

Adaptive point protectors for clearer printing of graphs with multiple traces. Point protectors are placed sparsely on runs as markers.

Better use of color for distinguishing runs. Optionally Logger Pro will use a single color in each run.

Time of day and Date in Time column and graphs has been added.

Optionally, horizontal axis labels may be rotated for graphs.

There is a new option to make all rows major tics on graphs. For example, a data table listing twelve month names can be set to display all months on the horizontal axis.

Additional control of number displays added in data tables and graph labels. User can force scientific notation.

**Styled Text**

You can customize the style of the text (including adding Greek characters) as it appears in text boxes, annotations, and graph labels.

**Data Collection**

Automatic saving of backup data files in case of power loss or crash enabled.

Space bar toggles data collection on and off if the selected page object does not have space as a valid character. For example, if a graph is selected, pressing the space bar will start and stop collection, just like the Collect button. However, if a text object is selected pressing space will enter a space character. The space bar is a convenient way to start data collection.

New unit-changing paradigm allows changing units after data collection. Units are no longer tied to a particular calibration.

**New Calculated Column Functions**

- Event counting with photogates
- Modulo
- Boolean functions
- Collapse indirect for better display of photogate data
- Blood pressure calculations
Improvements

It is now possible to collect data more slowly than one point every 4.4 hours when LabPro is connected to the computer. Remote data collection continues to have the 4.4-hour upper limit to the time between points.

Improved speed for all Mac OS versions, especially OS 9. In particular, opening files with many calculated columns, or storing runs with many calculated columns, is much faster.

Improved flexibility in displaying photogate data without blank cells. The data table can hide rows based on any single column.

Improved examine mode for video analysis. Video now snaps to frame when a marked point is selected.

Additionally:

- Support added for QuickTime 7.
- Clarified sensor calibration dialog box.
- Improved printing of fine graph lines by setting gray grid lines to black.
- Sounds in videos are now enabled on all platforms.
- Improved tolerance of videos with uneven time steps, making more videos usable for analysis.
- The aspect ratio of an inserted video is preserved at file open.

Logger Pro 3.3

Support for Multiple Devices

Logger Pro 3.3 supports LabPro, Go!Temp, Go! Link, and Ohaus Scout Pro balances. Up to four devices may be used simultaneously, with no more than two LabPros. On Windows, only one Ohaus scale can be connected by USB. Note: USB devices connect automatically if detected. Serial LabPro (and Ohaus on Windows) require manual connection using Connect Interface from the Experiment menu.

Icons for On-Line Devices

The second row in the toolbar now holds icons for each on-line device, followed by any live readouts. These icons are buttons to summon the sensor setup dialogs for each device. Offline devices do not appear in the toolbar, but are available in the Experiment menu.

Keyboard triggering

Keyboard triggering is a new option that allows you to start data collection with minimal delay by pressing the spacebar or return key on the keyboard. Enable keyboard triggering on the Data Collection dialog, Triggering tab. When keyboard triggering is active, clicking the Collect button merely prepares the system for data collection; collection begins at the next point when the spacebar is pressed.

Automatic Detection of Sensor Configuration
Logger Pro now detects the connection and removal of auto-ID sensors whenever live readouts are on and data collection is not active. When a sensor is added, a column is added to the Data Table. When a sensor is removed, its column is removed if the column is empty. To disable this behavior, turn off live readouts in the Experiment menu.

**Automatic Updating of Page Objects**

Logger Pro now automatically adds graphs or connects columns to existing graphs when sensors are added. This behavior simplifies setup, but it can also disrupt existing page layouts. As a result there are two new options to control automatic updates of page objects. You can separately enable or disable update page objects on File ➔ New (the default is on) and after File ➔ Open (the default is off).

**Single-Point Calibration**

Standard calibrations require two external references, but some sensors can be calibrated by setting an offset only, such as correcting a barometer for altitude. Logger Pro now allows single-point calibrations for any sensor that can be calibrated using two points.

**Identify Column Data Source**

Now that Logger Pro collects data from multiple devices it can be confusing as to where a given column is getting its values. You can now determine the source by device and channel number (eg, LabPro 2, CH 3) by inspecting the Column Options dialog for a given column. In addition, the interface dialogs (Experiments ➔ Set Up Sensors ➔ Show all Interfaces show the column name where the data from each channel is stored, in each sensor's Sensor Info display.

**Finer Control of Live Readouts**

All live readouts can still be disabled through the experiment menu but individual columns can be controlled through the column options. This can be very helpful to reduce the number of live readouts displayed on the tool bar. You can now turn on live readouts for the Motion Detector, although then the detector will click at all times.

**Export to GIS Format**

Logger Pro can export data in a form recognized by GIS software such as ArcView by ESRI.

**New Page Objects**

There are three new page objects. The Thermometer resembles a glass thermometer and can be used to display sensor readings. The Analog Gauge is a dial readout for sensor readings. The Animated Display is used to represent the motion of objects, usually from a Motion Detector column.

**New Global Preferences**
New preferences have been added. Optionally you can turn on a list of recently used files to be displayed in the File menu. This feature lets you quickly return to recent work, but some users may want to turn off the feature so that students cannot easily find other student work. The default is off. You can turn on large toolbar buttons so that Logger Pro will look nearly like Logger Lite. The default is set for standard Logger Pro buttons.

Supports New Sensors

The new Thermocouple (version shipping after May 2004) is now supported

Sensor Confirmation Dialog

The Sensor Confirmation dialog opens when you open an experiment file and Logger Pro does not detect all the necessary sensors. In version 3.2.1 and earlier we assumed that some non-auto ID sensors were present. Now we prompt, unless the Sensor Confirmation flag is cleared in the setting for that experiment file.

The Sensor Confirmation Dialog will disappear when you connect the requested auto ID sensors.

You can also indicate where any non-auto ID sensors are connected and manually close the dialog.

Logger Pro File Compatibility

Logger Pro saves files in the .cmbl file format. Logger Pro opens .xmlb, .gmbl, and .cmbl files as saved by Logger Pro version 3.0, 3.1, 3.2 and 3.2.1, and Logger Lite. Logger Pro will also open files saved in any version of Graphical Analysis 3 (.ga3 extension).

Other Changes

• Grouped graph behavior links axes and doesn’t group the objects themselves.
• Page objects now click to the front like windows in Finder and Explorer.
• Sensor polling for new auto ID sensors is now on whenever live readouts are on.
• Option to hide helper objects added.
• Predictions now take on the units of the graph.
• If no interface is connected when Logger Pro is launched, there is no longer a prompt to connect an interface, since Logger Pro is often used for manually entered data.

Experiment Files

• Experiment files have been updated.
• Experiment files have been added for Workshop Physics and CPU (Constructing Physics Understanding).
• Experiment files for Workshop Physics, CPU, Interactive Lecture Demonstrations, Real Time Physics, and Tools for Scientific Thinking have been moved to a folder titled Additional Physics.
Logger Pro 3.2.1

Supported Operating Systems

Mac OSX 10.3 is now supported.

Enhancements

- Several printing issues corrected.
- Fixed problem with serial connection to LabPro and Events with Entry data collection.
- Two-Photogate timing mode corrected.
- Remote data collection for 12000 points and four sensors now works correctly.

Experiment Files

Experiment files have been updated.

International

Logger Pro 3.2.1 is more compatible with international options.

Logger Pro File Compatibility

- Logger Pro files created in version 3.2 and 3.2.1 cannot be opened in older versions of Logger Pro.
- Logger Pro files created in version 3.0 and 3.1 may be opened in Logger Pro 3.2 and 3.2.1.

Logger Pro 3.2

Video Analysis

Quantitative position information can be obtained from inserted videos. User can set scale, define an origin, and track the positions of up to three objects. Video analysis data may be synchronized with sensor data.

Strip Charts

A new strip chart graph type has been added. If the width of a strip chart is less than the data collection time, then the strip chart will scroll right to left as data collection or replay proceeds.

Rate Functions
The rate functions used for heart rate and respiration rate calculations has been improved to use a moving window, allowing more frequent updates to the reported values.

**TI Connect Compatibility**

Logger Pro 3.2 is compatible with TI Connect versions 1.1, 1.2 and 1.3, and will use the installed USB Graph Link driver for calculator data import, if one is present.

**Optional LabPro OS update**

You have the option to update the LabPro Operating System (OS) from 6.26 to 6.27 to obtain improved Photogate and remote data collection behavior. If your LabPro has an OS older than 6.26, Logger Pro 3.2 will require an update to 6.27.

**Other changes**

- New and better sensor select dialog, with groupings of sensors.
- Handles 60 samples a minute or hour and other unusual values with better display of time values.
- Comma decimal separator now supported in addition to North American standard period decimal separator.
- Additional Tool Tips added.
- Extra smart sensors are ignored when opening a file.
- Stainless Steel Temperature probe calibration now supported using three reference temperatures.
- Removed extra Motion Detector calibrations because you are able to remove automatically generated calc columns now and they will not come back.
- Data can now start before the movie and still be synced.
- Improved Motion Detector calibrating.
- Large number support increased to $10^{50}$.

**Logger Pro 3.1**

A major development in Logger Pro 3 is the addition of all the features of the Graphical Analysis 3 Program. Below is an overview of these features.

**New Feature: Import From TI Device**

You can use Logger Pro 3 to transfer the data from a Texas Instruments graphing calculator to your computer for analysis or printing. Supported calculators are the TI-73, TI-73 Explorer, TI-82, TI-83, TI-83 Plus, TI-83 Plus Silver Edition, TI-84 Plus, TI-84 Plus Silver Edition, TI-85, TI-86, TI-89, TI-92, TI-92 Plus, and Voyage 200. To do this, you need a TI-GRAPH LINK cable, which is part of the TI-GRAPH LINK package and is sold by Vernier Software & Technology and other Texas Instruments dealers. This cable connects the TI graphing calculator to the serial or USB port of your computer.

**New Feature: Import From Data Pro**

The rate functions used for heart rate and respiration rate calculations has been improved to use a moving window, allowing more frequent updates to the reported values.
You can import data from a Palm handheld running DataPro into Logger Pro 3 for analysis or printing by selecting Import from…DataPro from the File menu. The Palm HotSync feature will also send data to Logger Pro. You will need the DataPro package, which is sold by Vernier Software & Technology.

New Feature: Movies

You can synchronize data collection and a movie of the experiment so that as you replay the movie, the data are replayed on the graph. Supported movie formats are Video clip (.avi) and all file formats supported by the QuickTime player. For a complete list of supported formats, visit: apple.com/quicktime/products/qt/specifications.html

New Feature: Draw Prediction

Added to Logger Pro 3 is the ability to predict what might happen in a given scenario. In certain lab experiments, you might want students to predict what is going to happen before they collect data. When you draw a prediction in Logger Pro 3 on the graphs, the prediction will be saved in the data table for comparisons.

New Feature: Control Devices

Using Logger Pro 3, you can power devices with an output signal from the function generator built into LabPro. You can also power and control devices using the Digital Control Unit.

New Feature: Pages

Logger Pro 3 now has pages. This allows you to have different layouts of data in a single file. One page might contain a graph and table with five different data collections. Then on different pages you might perform comparisons between different collections or just go into each collection in more detail. Each page can almost act as a different file while still sharing data with all the other pages.

New Feature: Insert Additional Objects

Added to Logger Pro 3 is the ability to add different objects besides the normal table and graph. These include rectangles and ovals. You can also add pictures to your experiment. Visual aids are especially useful for annotation, documentation, or instruction for a particular experiment.

New Feature: Data Browser

The Data Browser is a container for all the data in a Logger Pro file. In contrast, a given data table will not necessarily show all data columns.

For basic use of Logger Pro, you will not need to use the Data Browser. By default, all new data columns are added to all data tables. However, for more complex Logger Pro sessions, you may find it useful to display only a subset of the possible columns in a particular data table, or you may find it useful to not display a data table at all. In these cases, you will use the Data Browser to manipulate data columns and data sets.
What Changed from Logger Pro 2 to Logger Pro 3

Below are questions you may ask if you are already familiar with older versions of Logger Pro. Also provided is a list of improvements and new features of Logger Pro 3.

Interfaces

Logger Pro 3 supports the Vernier LabPro interface, the Vernier Go! Temp, the Vernier Go! Link, and the Ohaus Scout Pro balance. You can import data from text files, Excel files, different TI Graphing Calculators using a TI-GRAPH LINK cable, a Palm OS hand held using Data Pro and the LabPro. Logger Pro 3 will not work with the ULI, Serial Box Interface, or the MPLI.

LabPro and Collect buttons

The “Collect” button will no longer disappear when an interface is not connected. Instead there is constant feedback in the upper left-hand corner of the tool bar that tells the user whether or not the LabPro is connected. The Collect button will be faded if LabPro is not connected or recognized.

Windows

Logger Pro 3 now uses objects instead of windows. Every table, graph, meter, floating box and other window previously available in Logger Pro 2 are now separate objects in Logger Pro 3. Each object can still be resized and moved. Using the Page menu items, objects can be aligned, layered, grouped, un-grouped, and locked on a page. To insert most objects, just select the object you wish to add from the Insert menu. Floating boxes, now called helper objects, can still be found in the Analyze menu. Objects also have options, which can be opened by either double clicking on an object or selecting the desired object and choosing it from the Options menu.

Data Runs

Runs from Logger Pro 2 are now called Data Sets in Logger Pro 3.

Calculated columns

Formula Columns are now called Calculated Columns in Logger Pro 3. Other than the name change, calculated columns act the same way as Formula Columns in Logger Pro 2, with some additional features like error bar calculations.

Supported File Formats

Logger Pro 3 can open files in Logger Pro 3 (.cmbl or .xmbl), Logger Lite (.gmb) or Graphical Analysis 3 (.ga3) formats.

The Import Text feature, available from the File menu, can import data saved with the Export Text menu item or files created and saved from several other formats (e.g. Excel). The file must be in the tab-delimited text format used...
by Export Text (a .txt, .TEXT, .dat or .scv extension). Data are imported only into the latest data columns. You can also use this feature to import data prepared or collected in another program into Logger Pro.

**Sensor Setup**

The Setup menu has been removed. The Sensors Properties dialog has changed to the Sensor dialog, which can be accessed through the Experiment menu by choosing Set Up Sensors → Show All Interfaces from the Experiment menu. Each interface (LabPro, Go!Temp, Go! Link, or Ohaus balance) will have its own Sensor dialog.

If you are using an auto-ID sensor (such as a Stainless Steel Temperature Sensor or a Motion Detector), Logger Pro will identify your sensor at launch and load a default data collection mode. If your sensor does not auto-ID, choose an experiment file from the appropriate sensor folder or open the Sensor Setup dialog to manually configure Logger Pro for your sensor.

**Mode and Sampling**

In Logger Pro 3 these two separate pages have been combined into the Data Collection dialog from the Experiment menu. As you change the mode for the collection, you will notice the options available will also change according to your choice. These options are similar to those in Logger Pro 2.

**Repeat mode**

In Logger Pro 2 there was a separate Repeat mode for doing a Real Time Collection with repeats. In Logger Pro 3, Repeat is a checkbox option on the Time Based collection mode page of the Data Collection dialog.

**Photogate Timing modes**

Photogate Timing modes are not available in the Data Collection menu. Click on the Photogate Channel Box in the Sensor Setup window to change or select timing modes.

Logger Pro 3 also contains improved, more flexible functions (available in the New Calculated Column dialog from the Data Menu) to create calculated columns based on Photogate data.

**Radiation Monitor setup**

Once the Radiation Monitor is set up in the Sensor Setup window, the sensor status will be shown. The reading will be in Counts. The status of the Radiation Monitor is also displayed under the Toolbar. Click on the Radiation Monitor Channel Box in the Sensor Setup window to change or select timing intervals.

**FFT graph and table**

To insert an FFT graph, just select it from the Insert menu under Additional Graphs. In Logger Pro 3 there is no longer a separate FFT Table; instead FFT data are placed in the regular data table. The FFT Graph Options dialog is similar to the FFT Options dialog found in Logger Pro 2 except the two pages, Graph Features and FFT, have been combined into one page for easier access. FFTs have also been updated to allow more than one column to be plotted on a single FFT graph.
**Histogram graph and table**

To insert a Histogram graph, select Histogram from the Insert menu under Additional Graphs. In Logger Pro 3 there is no longer a separate Histogram Table; instead histogram data are placed in the regular data table. The Histogram Graph Options dialog is similar to the Histogram Options dialog found in Logger Pro 2, but the Graph Features page has been renamed to Graph Options and the Axis Options page is now the Bin & Count Options page. Histograms have also been updated to allow more than one column to be plotted on a single Histogram graph.

**Automatic/Manual Curve Fit**

Both types of curve fits have been merged into a single dialog in Logger Pro 3. Logger Pro 3 includes all Logger Pro 2 curve fit options and many new features. For automatic curve fits, you are now able to define your own function for a curve fit. The preview window now acts like a normal graph with the ability to zoom and auto scale. To switch between a manual and automatic curve fit, just click the appropriate radio button located in the upper right of the dialog under Fit Type. After performing an automatic curve fit, you can switch to a manual curve fit to get an even better fit if you desire. Sometimes it also helps to click the Try Fit button more than once to improve an automatic curve fit.

**Auto scale axes**

The functionality is now in the Axes Options tab of the Graph Options dialog, which can be called up by selecting Graph Options from the Options menu or by double clicking on the graph. Clicking on the axis labels on the graph may also change the axes. The scaling options for each axis are now independent of each other.

**Printing**

There is no longer an option to Print Screen. Instead, you can select Print from the File menu.

**Remote data retrieval**

Remote data retrieval from the LabPro is now in the Experiment menu. The functionality remains the same except that when you setup the LabPro for remote data, you can now print out your collection settings. Retrieval of data from the LabPro remains the same.

**Calibration Folder**

The calibration for sensors has been updated and is now stored in a database, so it's no longer necessary to supply a calibration folder.

**Experiment Folder**

The experiment folder is now located within the default folder, which can be defined in the Preferences dialog.
Over Range Autoscale option

The Over Range Autoscale option in the Graph behavior preferences page in the Preferences dialog has been removed. In Logger Pro 3 you can get the same effect by going to the Axes Options, which can be accessed either through the Graph Options (from the Options menu or double clicking on the graph). There are scaling options for each axis, so the autoscaling can be independent of each other.

Default Interface

Logger Pro 3 allows the creation of offline interfaces, replacing the single default interface of Logger Pro 2.

Options menu

The Options item found in the Experiment menu in Logger Pro 2 has moved to the File menu and renamed Settings for “this file.” You will find all of the experiment options in this dialog except the Enable automatic Curve Fit checkbox, which has been moved to the Preferences dialog. This new Settings dialog will save your options for the entire file, even after closing the file.

Store Latest Run

To store a set of data, choose Store Latest from the Experiment Menu.

Information about a file

The About "this file" item in the Help menu has been removed. In Logger Pro 3 you can place information about a page in the Page Options item in the Page menu. You can set the Page Information text in the Page Options dialog for page 1. You can also choose for it to be displayed when the page is first viewed, or when the file is opened.

Undo function

In Logger Pro 2 there was an undo command in the Edit menu. Logger Pro 3 expands on this command and allows you to undo almost any action that you perform. Collecting data, deleting or inserting an object, or changing the scale of the graph, for example can all be undone. If you perform too many undos, you now have the option to perform a redo that essentially undoes an undo.

Text Annotation

Text Annotation in Logger Pro 3 has been updated with many new features. For one, each text annotation can be connected to a point, thus describing information about what is happening to the graph at a particular point in time. As the graph is moved, the text annotation will stay with its point. You can also have more than one text annotation for a single point.

Stretchy Axes
Just outside the X or Y-axis line, you can use the cursor to manually rescale or stretch the axis.

LabPro Operating System Changes 6.26 (required) and 6.27 (optional)

Logger Pro 3 requires at least LabPro operating system 6.26. If a LabPro is connected with an earlier version, a dialog box will open offering to update the LabPro. You must update the LabPro to use it with Logger Pro 3. Beginning in version 3.2.1, Logger Pro will update the LabPro OS to version 6.27. This update is optional, and be applied by connecting a LabPro, clicking the LabPro icon in the toolbar, and clicking the Update LabPro OS button in the Sensors dialog for that LabPro.

In version 6.26 sensors were allowed to warm up after pressing the START/STOP button. In 6.27 the sensors are warmed up at setup time. After any warmup period has elapsed, data collection begins immediately on pressing START/STOP.

Version 6.27 updates and fixes:

- The build has DataMate 6.15 that includes the TI-73 Application.
- Fixed problem where communications were ignored during sensor warm up period.
- Fixed problem of photogate timebase and analog timebase being out of sync.
- Fixed problem of a first point of monitored (not collected) data being max value when using high speed data collection (DataMate),
- Fixed problem of corrupted data if photogate state transitions during start of pendulum experiment
- Fixed problem of using two Radiation monitors at the same time (Logger Pro)

LabQuest Operating System Changes 1.0 (required) and 1.1 (recommended)

Logger Pro 3 requires at least LabQuest operating system 1.0 however it is highly recommended that you upgrade to 1.1. If a LabQuest with 1.0 software is detected, a warning will be displayed advising that the LabQuest unit be upgraded. This message will be displayed every time the LabQuest is detected, but the LabQuest can still be used for most applications. If a Logger Pro feature requiring newer LabQuest software is used, unexpected results such as freezing, crashing, or data loss may occur. We strongly recommend updating LabQuest to 1.1 or newer. See www.vernier.com/labquest/updates/ for information on updates.

Version 1.1 updates and fixes:

- Rotary Motion sensor and Radiation Monitoring are supported.
- Internal Microphone is supported.

Vernier Software & Technology
info@vernier.com
www.vernier.com