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The Magnetic Field in a Slinky 
A solenoid is made by taking a tube and wrapping it with many turns of wire. A metal Slinky  is 
the same shape and will serve as our solenoid. When a current passes through the wire, a 
magnetic field is present inside the solenoid. Solenoids are used in electronic circuits or as 
electromagnets. 

In this lab we will explore factors that affect the magnetic field inside the solenoid and study how 
the field varies in different parts of the solenoid. By inserting a Magnetic Field Sensor between 
the coils of the Slinky, you can measure the magnetic field inside the coil. You will also measure 
µ0, the permeability constant. The permeability constant is a fundamental constant of physics. 

To determine the current through the solenoid you will measure the voltage across a 1 Ω resistor 
in series with the solenoid. Using Ohm’s law, I = V/R, we find, for example, that a voltage of 2 V 
across the resistor will correspond to a current of 2 A through the resistor. 

OBJECTIVES 
•  Determine the relationship between magnetic field and the current in a solenoid. 
•  Determine the relationship between magnetic field and the number of turns per meter in a 

solenoid. 
•  Study how the field varies inside and outside a solenoid. 
•  Determine the value of µ0, the permeability constant. 

 
 

Figure 1 

MATERIALS 
LabQuest ammeter 
LabQuest App cardboard spacers 
Vernier Magnetic Field Sensor clip-lead connecting wires 
Slinky  momentary-contact switch 
meter stick tape and cardboard 
DC power supply Logger Pro or graph paper (optional) 
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INITIAL SETUP 
1. Stretch the Slinky until it is about 1 m in length. The distance between the coils should be 

about 1 cm. Use a non-conducting material (tape, cardboard, etc.) to hold the Slinky at this 
length. 

2. Set up the circuit and equipment as shown in Figure 1.  

3. Set the switch on the Magnetic Field Sensor to 0.3 mT (high amplification). Connect the 
Magnetic Field Sensor to LabQuest. Choose New from the File menu. If you have an older 
sensor that does not auto-ID, manually set up the sensor.  

 4. Turn on the power supply and adjust it so that the current is 2.0 A when the switch is held 
closed. Open the switch after you make the adjustment. 

Warning: This lab requires fairly large currents to flow through the wires and Slinky. Only 
close the switch so the current flows when you are taking a measurement. The Slinky, wires, 
and possibly the power supply may overheat if left on continuously. 

PRELIMINARY QUESTIONS 

1. Hold the switch closed. Place the Magnetic Field Sensor between the turns of the Slinky near 
its center. Rotate the sensor and determine which direction gives the largest positive magnetic 
field reading. What direction is the white dot on the sensor pointing? 

2. What happens if you rotate the white dot to point the opposite way? What happens if you 
rotate the white dot so it points perpendicular to the axis of the solenoid? 

3. Insert the Magnetic Field Sensor through different locations along the Slinky to explore how 
the field varies along the length. Always orient the sensor to read the maximum magnetic 
field at that point along the Slinky. How does the magnetic field inside the solenoid seem to 
vary along its length?  

4. Check the magnetic field intensity just outside the solenoid. Is it different from the field 
inside the solenoid? Open the switch when you are finished. 

PROCEDURE 
Part I How Is the Magnetic Field in a Solenoid Related to the Current? 

For the first part of the experiment you will determine the 
relationship between the magnetic field at the center of a solenoid 
and the current flowing through the solenoid. As before, leave the 
current off except when making a measurement. 

1. Place the Magnetic Field Sensor between the turns of the Slinky 
near its center. 

 
Figure 2 
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2. Close the switch and rotate the sensor so that the white dot points directly down the long axis 
of the solenoid, in the direction that gives the maximum positive reading. This will be the 
position for all of the magnetic field measurements for the rest of this lab. Open the switch to 
turn off the current. 

 3. Zero the magnetic field sensor to remove readings due to the Earth’s magnetic field, any 
magnetism in the metal of the Slinky, or the table. When the readings on the screen stabilize, 
choose Zero from the Sensors menu. When the process is complete, the readings for the 
Magnetic Field Sensor should be close to zero. 

4. Now you are ready to collect magnetic field data as a function of current. 
a. Adjust the current so that it is 0.0 A. 
b. Start data collection. 
c. Wait one second and close the switch. 
d. When data collection is finished, open the switch. 

 
5. Determine the average magnetic field while the switch was closed. 

a. Tap and drag your stylus across the region when the switch was closed to select these data 
points. 

b. Choose Statistics from the Analyze menu.  
c. Record the average (mean) magnetic field in the data table. 

 
6. Increase the current by 0.5 A, and repeat Steps 4–5. 

 7. Repeat Steps 6 up to a maximum of 2.0 A. 

 8. Answer the Analysis questions for Part I before proceeding to Part II. 

 
9. If the graph appears linear, fit a straight line to your data. 

a. Choose Curve Fit from the Analyze menu. 
b. Select Linear as the Fit Equation. The linear-regression statistics for these two data 

columns are displayed. 
c. Record the slope and y-intercept of the regression line in the data table, along with their 

units. 
d. Select OK. 

 
  10. Count the number of turns of the Slinky and measure its length. If you have any unstretched 

part of the Slinky at the ends, do not count it for either the turns or the length. Calculate the 
number of turns per meter of the stretched portion. Record the length, turns, and the number 
of turns per meter in the data table. 

Part II How is the Magnetic Field in a Solenoid Related to the Spacing of the Turns? 

For the second part of the experiment, you will determine the relationship between the 
magnetic field in the center of a coil and the number of turns of wire per meter of the 
solenoid. You will keep the current constant. Leave the Slinky set up as shown in Figure 1. 
Position the sensor as it was before, so that it measures the field down the middle of the 
solenoid. You will be changing the length of the Slinky from 0.5 to 2.0 m to change the 
number of turns per meter. 

 11. Use the length and number of turns of your Slinky from Part I and record the values in the 
first line of the data table. 
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 12. Since the Slinky is made of an iron alloy, it can be magnetized itself. Moving the Slinky 
around can cause a change in the field, even if no current is flowing. This means you will 
need to zero the reading each time you move or adjust the Slinky, even if the sensor does not 
move. When the readings on the screen stabilize, choose Zero from the Sensors menu. When 
the process is complete, the readings for the Magnetic Field Sensor should be close to zero 

 13. Close the switch to turn on the current, and adjust the current to 1.0 A. Open the switch. 
 14. Measure the magnetic field. 

a. Start data collection. 
b. Wait one second and close the switch. 
c. When data collection is finished, open the switch. 

 
 15. Determine the average magnetic field while the switch was closed. 

a. Tap and drag your stylus across the region when the switch was closed to select these data 
points. 

b. Choose Statistics from the Analyze menu.  
c. Record the average (mean) magnetic field in the data table. 

 
 16. Repeat Steps 14 and 15 after changing the length of the Slinky to 0.5 m, 1.5 m, and 2.0 m. 

Record the length in the data table. Keep the number of turns and the current the same each 
time. Each time, zero the Magnetic Field Sensor with the current off. 
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DATA TABLE 
Part I 

Current in solenoid I Magnetic field B
(A) (mT) 

0.5  

1.0  

1.5  

2.0  

  

Length of solenoid (m)  

Number of turns  

Turns/m (m–1)  

Magnetic field vs. Current 

Slope  

Intercept  

Part II 

Length of Solenoid Turns/meter n Magnetic Field B 
(m) (m–1) (mT) 

   

   

   

   

Magnetic field vs. Turns/meter n 

Slope  

Number of turns in Slinky  

Current (A)  
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ANALYSIS 
Part I 

1. Plot a graph of magnetic field vs. current. 
a. Disconnect the Magnetic Field Sensor from LabQuest. 
b. Choose New from the File menu. 
c. Tap Table to display the data table. 
d. Tap the X column heading and Enter the Name (Current) and Units (A). Select OK. 
e. Tap the Y column heading and enter the Name (Mag Field) and Units (mT). Select OK. 
f. Select the first cell in the Current column and enter the first value. 
g. Move to the first cell in the Mag Field column and enter the first value. 
h. Continue with this process, entering the data pairs until you have entered all of the data 

pairs. 
i. Tap Graph to view a graph of magnetic field vs. current. 

 
2. Inspect your sketched or printed graph of magnetic field B vs. the current I through the 

solenoid. How is magnetic field related to the current through the solenoid? 

3. If the points on your graph of magnetic field vs. current through the coils follow a generally 
linear path, fit a straight line to the data. 

a. Choose Curve Fit from the Analyze menu. 
b. Select Linear as the Fit Equation. The linear-regression statistics are displayed. 
c. Record the slope and y-intercept of the regression line in the data table, along with their 

units. 
d. Select OK and print or sketch your graph. 

 
4. Inspect the equation of the best-fit line to the field vs. current data. What are the units of the 

slope? What does the slope measure? 

Part II 

5. For each of the measurements of Part II, calculate the number of turns per meter. Enter these 
values in the data table. 

6. Plot a graph of magnetic field vs. number of turns per meter. 
a. Disconnect the Magnetic Field Sensor from LabQuest. 
b. Choose New from the File menu. 
c. Tap Table to display the data table. 
d. Tap the X column heading and Enter the Name (Number) and Units ( ). Select OK. 
e. Tap the Y column heading and enter the Name (Mag Field) and Units (mT). Select OK. 
f. Select the first cell in the Number column and enter the first value. 
g. Move to the first cell in the Mag Field column and enter the first value. 
h. Continue with this process, entering the data pairs until you have entered all of the data 

pairs. 
i. Tap Graph to view a graph of magnetic field vs. number of turns per meter. 

 
7. How is magnetic field related to the turns/meter of the solenoid? 
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8. If the points on your graph of magnetic field vs. number of turns per meter follow a generally 
linear path, fit a straight line to the data. 

a. Choose Curve Fit from the Analyze menu. 
b. Select Linear as the Fit Equation. The linear-regression statistics are displayed. 
c. Record the slope and y-intercept of the regression line in the data table, along with their 

units. 
d. Select OK and print or sketch your graph. 

 
9. From Ampere’s law, it can be shown that the magnetic field B inside a long solenoid is  

B nI= µ0  
where µ0 is the permeability constant. Do your results agree with this equation? Explain. 

 10. Assuming the equation in the previous question applies for your solenoid, calculate the value 
of µ0 using your graph of B vs. n. You will need to convert the slope to units of T•m from 
mT•m. 

 11. Look up the value of µ0, the permeability constant. Compare it to your experimental value. 
Note that any error in the value of the resistor will influence your current measurements, and 
so your value of µ0. 

 12. Was your Slinky positioned along an east-west, north-south, or on some other axis? Will this 
have any effect on your readings? 

EXTENSIONS 
1. Use the graph obtained in Part I to determine the value of µ0. 

2. Carefully measure the magnetic field at the end of the solenoid. How does it compare to the 
value at the center of the solenoid? Try to prove what the value at the end should be. 

3. Study the magnetic field strength inside and around a toroid, a circular-shaped solenoid. 

4. If you have studied calculus, refer to a calculus-based physics text to see how the equation for 
the field of a solenoid can be derived from Ampere’s law. 

5. If you look up the permeability constant in a reference, you may find it listed in units 
of henry/meter. Show that these units are the same as tesla-meter/ampere. 

6. Take data on the magnetic field intensity vs. position along the length of the solenoid. Check 
the field intensity at several distances along the axis of the Slinky past the end. Note any 
patterns you see. Plot a graph of magnetic field (B) vs. distance from center. Use Logger Pro 
or graph paper. How does the value at the end of the solenoid compare to that at the center? 
How does the value change as you move away from the end of the solenoid 

7. Insert a steel or iron rod inside the solenoid and see what effect that has on the field intensity. 
Be careful that the rod does not short out with the coils of the Slinky. You may need to 
change the range of the Magnetic Field Sensor.
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SAMPLE RESULTS 
Part I 

Current in solenoid I Magnetic field B 
(A) (mT) 

xxxx xxxx 

xxxx xxxx 

xxxx xxxx 

xxxx xxxx 

  

Length of solenoid (m) xxxx 

Number of turns xxxx 

Turns/m  xxxx 

Part II 

Length of solenoid Turns/Meter n Magnetic field B 
(m)  (mT) 

xxxx xxxx xxxx 

xxxx xxxx xxxx 

xxxx xxxx xxxx 

xxxx xxxx xxxx 

Number of turns in Slinky xxxx 
 

In each case, a field 
measurement consists of 
starting data collection 
and then turning on the 
current through the 
Slinky. The graph here 
shows the magnetic field 
measurement for four 
different currents. To read 
the field, drag across most 
of the current-on portion, 
and click the Statistics 
button.  
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Magnetic field strength vs. current run 

through the Slinky 
Magnetic field strength vs. turns per meter 

in a Slinky 
 

ANSWERS TO PRELIMINARY QUESTIONS 

ANSWERS TO ANALYSIS QUESTIONS 

EXTENSION NOTES 
 

 
 

Answers have been removed from the online versions of Vernier 
curriculum material in order to prevent inappropriate student use.  
Graphs and data tables have also been obscured.  Full answers and 
sample data are available in the print versions of these labs. 


